Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Little Help

  1. #1
    Hatchling
    Joined
    Aug 29 2013
    Posts
    4

    Little Help

    I started on Arkadia. Went to the military base, got my rover (the first vehicle) and went to spawn it. It disappears right in front of me and some time later gets put in the planetary storage. I walk to the first guard tower and find it, try to spawn again and it disappears again. Im really trying to give this game a good chance, but am finding it a little annoying that there is no one in game to talk to in "Local" chat.

    Do I need to deposit money or something to fully active the game?

    Also - im reading that Calypso is the place to be? Is this true for starting players?

  2. Sponsored Links
  3. #2
    Moderator
    Joined
    May 13 2011
    Location
    Australia
    Posts
    580
    Hi there, and welcome to EU and EF.

    A Rover you say ? I thought the beginners free vehicle on Arkadia was a Hoverpod ? Perhaps it's changed since I was last there...

    No, there is never any requirement to deposit. Whether you do so or not is entirely a decision for you to make. Playing without depositing does take a good bit more patient and persistence, but is certainly not impossible.

    I'm not ingame atm - and if I was, am not based on Planet Arkadia - so can't help you with your specific issue. But others here will be, and will undoubtedly respond.

    In the meantime, you might wish to check out Arkadian planet partner's own forum as well: www.arkadiaforum.com

    Calypso is the oldest of the planets, and so has the largest playerbase as well as the largest economy. However, Arkadia has a strong economy as well, and although you haven't seen them yet, has many dedicated residents.

  4. #3
    Guardian
    Joined
    May 30 2011
    Location
    UK
    Posts
    244
    In addition - 'local' chat really is local. The map is big, and if there is nobody near you then nobody will respond to chat.

    When you spawn the vehicle check that the little green flash under it appears. This means that it is OK to spawn it here.

    The other point is that a vehicle will go to the main storage if left for a period. It shouldn't do it immediately.

  5. #4
    Old
    Joined
    May 13 2011
    Location
    USA
    Posts
    64
    Haven't heard of this happening on Arkadia but it happens a lot on Calypso Gateway. When a new player spawns their vehicle, they can't see it but it is there. A quick relog fixes the problem on Calypso Gateway. The vehicles do recall to storage after 10 minutes out of radar range so that is likely happening. Get the vehicle out of storage, spawn it then do a quick relog and get back before 10 minutes elapses. You hopefully will see the vehicle where you spawned it.

    Good luck.

  6. #5
    Young
    Joined
    Aug 25 2013
    Location
    Aurora, CO
    Posts
    11
    My Avatar has just recently started on Arkadia and I got the Alienware Hoverpod ... not sure if different folks get different intro vehicles for some reason.

    I'll probably be online sometime tonight (US-Mtn Time), if you need some help ... although being a total noob myself, I don't know how much I can do. I have gotten my vehicle to work and have been running around mining (and some small amount of sweating/hunting).

    I have encountered the issue of not being able to spawn a vehicle, but I found it back in my personal storage when I couldn't spawn it. I haven't personally encountered it disappearing and showing up again in the storage terminals.

  7. #6
    Guardian saradu's Avatar
    Joined
    Nov 21 2011
    Location
    Netherlands
    Posts
    312
    Quote Originally Posted by Max Hash View Post
    I started on Arkadia. Went to the military base, got my rover (the first vehicle) and went to spawn it. It disappears right in front of me and some time later gets put in the planetary storage. I walk to the first guard tower and find it, try to spawn again and it disappears again. Im really trying to give this game a good chance, but am finding it a little annoying that there is no one in game to talk to in "Local" chat.

    Do I need to deposit money or something to fully active the game?

    Also - im reading that Calypso is the place to be? Is this true for starting players?
    Mine kept doing this to me so I passed it over to my hubby and he gave it a shot. Although it was still invisible it was there, just aim your repair tool at it or where you think it should be and start to repair and it should instantly show up. At least that is what it did for us.
    Mrs. Roni RL Jan 21, 2014
    Started EU 11-02-2011


  8. #7
    Hatchling
    Joined
    Aug 29 2013
    Posts
    4
    Thank you for the advice. Im coming from Eve Online (still play it though) and am used to a very high learning curve. My idea of local is anyone in the same system. Ill have to adjust my thinking considerably. The reason im trying this game is because there seems to be so much that can be done. Right now its very "Elder Scrolls" in that i have no skills, my weapon takes 15 hits to kill a rat (green thing?) so im basically an infant in the world.

    Ill try again later today. Im assuming that i look up one of your names in private chat, or try to add you to my friends list if i want to send an email in game.

  9. #8
    Young
    Joined
    Aug 25 2013
    Location
    Aurora, CO
    Posts
    11
    From what I've seen, you need to be Friends with someone to send them a Private Message (although as another Noob, there may be another way to do it). But so far, folks have been pretty good at accepting Friend requests when I've wanted to contact them in-game.

    You can see who is online via the Player Registry, but I haven't found a way to identify how to send a message to someone that is online in the Registry other than sending them a Friend request first.

  10. #9
    Moderator
    Joined
    May 13 2011
    Location
    Australia
    Posts
    580
    Quote Originally Posted by Boegs
    ...I haven't found a way to identify how to send a message to someone that is online in the Registry other than sending them a Friend request first.
    That is indeed the only way to do it.

  11. #10
    Dominant
    Joined
    Aug 09 2011
    Posts
    484
    Quote Originally Posted by Boegs View Post
    From what I've seen, you need to be Friends with someone to send them a Private Message (although as another Noob, there may be another way to do it).
    If you can see the avatar, you can right click on them to send a private message request.

    Quote Originally Posted by Max Hash View Post
    I started on Arkadia. Went to the military base, got my rover (the first vehicle) and went to spawn it. It disappears right in front of me and some time later gets put in the planetary storage.
    In addition to relogging, I find that new players sometimes have something wrong with their installation that prevents them from seeing vehicles. Log out of the game, then in the client loader click Tools, and choose repair.

 

 
Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •